OEC RepairLink Unavailable

Incident Report for Tekmetric

Resolved

The OEC RepairLink disruption has been solved.
Posted Jun 17, 2026 - 02:45 EDT

Identified

We are aware of increased errors impacting OEC RepairLink-related workflows in Tekmetric.

This appears to be related to a service disruption with OEC RepairLink. Our team is monitoring the issue and will provide updates as more information becomes available.
Posted Jun 16, 2026 - 16:15 EDT
This incident affected: Integrations.