SpeedDial 2.0 integration issues

Incident Report for Tekmetric

Resolved

The incident has been resolved
Posted Sep 18, 2026 - 15:20 EDT

Monitoring

WorldPac are aware of an issue on their side and are working to resolve. Errors now are intermittent.
Posted Sep 18, 2026 - 12:39 EDT

Investigating

We are currently investigating an issue authenticating and search for parts with SpeedDial 2.0.
Posted Sep 18, 2026 - 12:09 EDT
This incident affected: Integrations.