AWS Incident impact

Incident Report for Tekmetric

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 19:57 EDT

Update

Due to the ongoing AWS incident, reporting in Tekmetric is currently delayed. All records are being properly registered, but data will not be displayed in real time.

The ongoing AWS incident is also impacting our support and training software providers. As a result, customers may experience intermittent issues when trying to reach our Support Team or training materials.
Posted Oct 20, 2025 - 11:36 EDT

Update

Ongoing AWS issues are causing performance degradation in Tekmetric.
Posted Oct 20, 2025 - 09:49 EDT

Monitoring

Webhook delivery and one-way texting are now operating normally. We’ll continue monitoring to ensure all systems remain stable and fully functional.
Posted Oct 20, 2025 - 08:11 EDT

Investigating

A recent AWS incident is causing delays with webhook delivery and one-way texting. We’re monitoring the issue and will share updates as services recover.
Posted Oct 20, 2025 - 07:30 EDT
This incident affected: Application and Webhooks.