Cannot Print PDFs

Incident Report for Tekmetric

Resolved

This incident has been resolved.
Posted Jul 01, 2024 - 15:40 EDT

Investigating

We are currently investigating an issue with printing PDFs
Posted Jul 01, 2024 - 15:32 EDT
This incident affected: Application.