Our partner PartsTech is experiencing partial outage

Incident Report for Tekmetric

Resolved

This incident has been resolved.
Posted Sep 23, 2025 - 17:22 EDT

Update

We are continuing to investigate this issue.
Posted Sep 23, 2025 - 17:21 EDT

Update

We are continuing to investigate this issue.
Posted Sep 23, 2025 - 12:30 EDT

Update

We've taken actions to ensure system stability while PartsTech outage is ongoing. Tekmetric system stability should be gradually restoring over the next few minutes.
Posted Sep 23, 2025 - 11:23 EDT

Investigating

Our partner PartsTech is currently experiencing a partial outage affecting parts ordering.
Posted Sep 23, 2025 - 11:08 EDT
This incident affected: Integrations.