Latency in production environment

Incident Report for Tekmetric

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 22:59 EDT

Monitoring

We are seeing performance come back to normal. We are monitoring and digging into a root cause.
Posted Apr 08, 2026 - 19:50 EDT

Investigating

We are seeing some performance issues in the production environment and investigating. We will post an update when we have identified the issue.
Posted Apr 08, 2026 - 19:39 EDT
This incident affected: Application and API.